M5POST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   M5POST - BMW M5 Forum > F10 M5 Forum > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Coding

Post Reply
 
Thread Tools Search this Thread
      01-10-2013, 03:22 PM   #1
mwlmd
Major
 
mwlmd's Avatar
 
Drives: F10 M5
Join Date: May 2009
Location: Portland, OR

Posts: 1,196
iTrader: (0)

F10 Navigation is horrible!!

I know this has been mentioned before but I had never experienced what folks were talking about. In the past 10 days I have tried to use my NAV 3 times by entering a street address and starting guidance. EACH time my new M5 took me to the WRONG place!!! Once "at the destination" I would search the same address on my iPhone which would direct me to the correct place which on average is about 5 blocks away. How can this be the case? Is anyone aware of a software update or any such thing that fixes this? This basically makes the NAV unusable as far as I am concerned. Very frustrating.
__________________
F10 M5
Alpine/Sakhir/Anthracite/DCT

HRE P101. Akrapovič evolution. H&R. Bell StiR+ Laser Interceptor quad. IND cosmetics. 3M CR50.
mwlmd is offline   United_States
0
Reply With Quote
      01-10-2013, 03:28 PM   #2
Rob///M5
Major
 
Rob///M5's Avatar
 
Drives: 2013 M5 SSII
Join Date: Aug 2012
Location: San Diego

Posts: 1,342
iTrader: (0)

Garage List
2013 BMW M5  [5.00]
Agree it's completely unusable. Ridiculous
Rob///M5 is offline  
0
Reply With Quote
      01-10-2013, 03:42 PM   #3
MSPORTWORLD
Major
 
MSPORTWORLD's Avatar
 
Drives: '11 M3 MW/FR - '12 M3 FO/SC
Join Date: Dec 2008
Location: California

Posts: 1,179
iTrader: (2)

Garage List
First world problems...
__________________
MSPORTWORLD is offline   United_States
0
Reply With Quote
      01-10-2013, 03:44 PM   #4
RPiM5
Brigadier General
 
RPiM5's Avatar
 
Drives: Riviera Blue F10 M5(Mika)
Join Date: Apr 2012
Location: Washington, D.C.

Posts: 4,079
iTrader: (0)

I haven't experienced your woes yet. My Nav has been spot on every time so far. Sorry to hear about it bro.
__________________
Currently saving my pennies for the 911-Fighter. The McLaren P13 500S.
RPiM5 is offline  
0
Reply With Quote
      01-10-2013, 04:03 PM   #5
ucla95
Striker
 
Drives: formerly F10 M5, E63S on order
Join Date: May 2012
Location: USA

Posts: 471
iTrader: (0)

Quote:
Originally Posted by mwlmd View Post
In the past 10 days I have tried to use my NAV 3 times by entering a street address and starting guidance. EACH time my new M5 took me to the WRONG place!!! Once "at the destination" I would search the same address on my iPhone which would direct me to the correct place which on average is about 5 blocks away. How can this be the case? Is anyone aware of a software update or any such thing that fixes this? This basically makes the NAV unusable as far as I am concerned. Very frustrating.
This has happened to me more times than I can count. I can't use the NAV anymore. It's the worst I've ever experienced.
ucla95 is offline  
0
Reply With Quote
      01-10-2013, 04:06 PM   #6
M54ccibo
Major
 
M54ccibo's Avatar
 
Drives: '13 F10 M5 AW/SO
Join Date: Apr 2012
Location: Orange County, CA

Posts: 1,373
iTrader: (0)

This is good to know. I don't use it often, and when I do I usually send the address to the car via google maps. So far, no issues there for me.

Is it as bad as iOS 6 Apple Maps? That was horrendous.
__________________
Current ///M: '13 F10 M5, Alpine Weiss III/Sakhir Orange Full
BBS FI, Akrapovič Evolution, CF Delete, H&R Sport Springs, iND Cosmetics, Color matched M-Performance Spoiler, V1 Hardwire, Coded
Follow the M5army on Facebook and Youtube
M54ccibo is offline   United_States
0
Reply With Quote
      01-10-2013, 04:09 PM   #7
ucla95
Striker
 
Drives: formerly F10 M5, E63S on order
Join Date: May 2012
Location: USA

Posts: 471
iTrader: (0)

Quote:
Originally Posted by M54ccibo View Post
Is it as bad as iOS 6 Apple Maps? That was horrendous.
Far far worse than iOS6 imho
ucla95 is offline  
0
Reply With Quote
      01-10-2013, 04:12 PM   #8
AGS
Captain
 
AGS's Avatar
 
Drives: 2013 F10 M5
Join Date: May 2012
Location: NJ

Posts: 702
iTrader: (0)

Same here. I've resorted to mapping it on google maps, then using google's "Send" function to send the directions to the car.
__________________
Current: 2013 Monte Carlo Blue F10 M5 (ED on 9/1/12), 2014 Anvil Willys Wheeler Jeep Wrangler (weekend toy)
Previous: 2009 Carbon Black E60 M5, 2006 Silverstone II E60 M5, 2003 Sterling Grey E39 M5, 2000 Anthracite E39 540i6, 1998 Jeep Grand Cherokee 5.9 Limited, 1990 Eagle Talon TSi AWD, 1978 Mazda RX-7
AGS is offline  
0
Reply With Quote
      01-10-2013, 04:16 PM   #9
M54ccibo
Major
 
M54ccibo's Avatar
 
Drives: '13 F10 M5 AW/SO
Join Date: Apr 2012
Location: Orange County, CA

Posts: 1,373
iTrader: (0)

Quote:
Originally Posted by ucla95 View Post
Far far worse than iOS6 imho
Damn. That's bad.
__________________
Current ///M: '13 F10 M5, Alpine Weiss III/Sakhir Orange Full
BBS FI, Akrapovič Evolution, CF Delete, H&R Sport Springs, iND Cosmetics, Color matched M-Performance Spoiler, V1 Hardwire, Coded
Follow the M5army on Facebook and Youtube
M54ccibo is offline   United_States
0
Reply With Quote
      01-10-2013, 04:35 PM   #10
mindlessmark07
Lieutenant
 
mindlessmark07's Avatar
 
Drives: 2013 F10 M5
Join Date: Dec 2012
Location: Orange County CA

Posts: 565
iTrader: (0)

Quote:
Originally Posted by AGS
Same here. I've resorted to mapping it on google maps, then using google's "Send" function to send the directions to the car.
No problems here. Where do you guys live? I use it all the time.
__________________

MindlessMark07
///2013 M5 Alpine White/Black,Orange County CA\\\
mindlessmark07 is offline  
0
Reply With Quote
      01-10-2013, 04:36 PM   #11
nybimmerfan
Lieutenant
 
nybimmerfan's Avatar
 
Drives: 6-Spd Manual MCB M5
Join Date: May 2012
Location: NY

Posts: 431
iTrader: (0)

Quote:
Originally Posted by mwlmd View Post
I know this has been mentioned before but I had never experienced what folks were talking about. In the past 10 days I have tried to use my NAV 3 times by entering a street address and starting guidance. EACH time my new M5 took me to the WRONG place!!! Once "at the destination" I would search the same address on my iPhone which would direct me to the correct place which on average is about 5 blocks away. How can this be the case? Is anyone aware of a software update or any such thing that fixes this? This basically makes the NAV unusable as far as I am concerned. Very frustrating.
A GPS system is only as good as the provided digital map. I have never experienced any problems yet with the M5 NAV system in the Queens,NYC and Nassau County LI area where I have used it so far. I have not had the chance using it around Manhattan where due to the tall buildings, GPS signal is sometimes lost (the system needs to be able to get signals from at least 4 satellites to pinpoint the car's location in space.

I have extensively used the system with the european digital map provided in a USB during my European Delivery trip from Munich (Germany) to Provence (Southern France) and every destination was spot on -- mind you I went to interesting and sometimes obscure European towns where an average tour won't include in their itinerary. The only time that I thought that the GPS lead me astray was to St. Paul de Vence in Southern France, but it turned out that I did not follow exactly where the GPS was leading me, however, once I did the turns exactly as instructed, I got there. Have you had BMW service take a look at you GPS system as something may not be properly working?
nybimmerfan is offline   United_States
0
Reply With Quote
      01-10-2013, 04:45 PM   #12
AGS
Captain
 
AGS's Avatar
 
Drives: 2013 F10 M5
Join Date: May 2012
Location: NJ

Posts: 702
iTrader: (0)

Quote:
Originally Posted by mindlessmark07 View Post
No problems here. Where do you guys live? I use it all the time.
It's hit or miss. I'm in NJ, and the last time I used it I ended up at an address about 1 to 1.5 miles from the correct building. However on New Year's Eve I used it for a trip to PA and it worked just fine.
__________________
Current: 2013 Monte Carlo Blue F10 M5 (ED on 9/1/12), 2014 Anvil Willys Wheeler Jeep Wrangler (weekend toy)
Previous: 2009 Carbon Black E60 M5, 2006 Silverstone II E60 M5, 2003 Sterling Grey E39 M5, 2000 Anthracite E39 540i6, 1998 Jeep Grand Cherokee 5.9 Limited, 1990 Eagle Talon TSi AWD, 1978 Mazda RX-7
AGS is offline  
0
Reply With Quote
      01-10-2013, 05:06 PM   #13
cmhsam
Major
 
Drives: 2013 F10 M5
Join Date: Mar 2012
Location: USA

Posts: 1,279
iTrader: (0)

Quote:
Originally Posted by AGS View Post
Same here. I've resorted to mapping it on google maps, then using google's "Send" function to send the directions to the car.
How do you do this?
cmhsam is offline  
0
Reply With Quote
      01-10-2013, 05:19 PM   #14
mwlmd
Major
 
mwlmd's Avatar
 
Drives: F10 M5
Join Date: May 2009
Location: Portland, OR

Posts: 1,196
iTrader: (0)

I used it in Europe with no issues. It just seems that the interface between map and sat here in Portland, OR is off.

It is weird because I have never had an issue before on any car with Nav dating back to 2005 or so.
__________________
F10 M5
Alpine/Sakhir/Anthracite/DCT

HRE P101. Akrapovič evolution. H&R. Bell StiR+ Laser Interceptor quad. IND cosmetics. 3M CR50.
mwlmd is offline   United_States
0
Reply With Quote
      01-10-2013, 05:32 PM   #15
RPiM5
Brigadier General
 
RPiM5's Avatar
 
Drives: Riviera Blue F10 M5(Mika)
Join Date: Apr 2012
Location: Washington, D.C.

Posts: 4,079
iTrader: (0)

Quote:
Originally Posted by mwlmd View Post
I used it in Europe with no issues. It just seems that the interface between map and sat here in Portland, OR is off.

It is weird because I have never had an issue before on any car with Nav dating back to 2005 or so.
Yeah I agree. I never had an issue with the Nav while on Euro Delivery. It was always accurate. We never ended up in Slovakia while trying to get to Berlin for example. "I once stabbed a woman in Berlin!" Haha! (Bonus points if you know what movie that is from!) Come to think about it, I never had an issue with my old 2006 E60 M5 Nav either, it was always accurate as well. It could be GPS related. Or it could be the glitch in the system when the government is tracking where you are. Or it could be like Deja-Vu in the Matrix, when your about to be attacked by agents. Who knows!
__________________
Currently saving my pennies for the 911-Fighter. The McLaren P13 500S.
RPiM5 is offline  
0
Reply With Quote
      01-10-2013, 05:54 PM   #16
Mperial
Second Lieutenant
 
Mperial's Avatar
 
Drives: 2013 M5 Imperial Blue Metallic
Join Date: Oct 2012
Location: NYC

Posts: 207
iTrader: (0)

Quote:
Originally Posted by nybimmerfan View Post
A GPS system is only as good as the provided digital map. I have never experienced any problems yet with the M5 NAV system in the Queens,NYC and Nassau County LI area where I have used it so far. I have not had the chance using it around Manhattan where due to the tall buildings, GPS signal is sometimes lost (the system needs to be able to get signals from at least 4 satellites to pinpoint the car's location in space.
+1
Manhattan is fine albeit a bit longer to load up.
Mperial is offline   United_States
0
Reply With Quote
      01-10-2013, 06:13 PM   #17
AGS
Captain
 
AGS's Avatar
 
Drives: 2013 F10 M5
Join Date: May 2012
Location: NJ

Posts: 702
iTrader: (0)

Quote:
Originally Posted by cmhsam View Post
How do you do this?
First google an address.
Left click on the pindrop, select more, then select send.
When the dialog box comes up select send to car.
Under the "Make" select BMW and enter the email address you have set up with BMW Assist.
Click the Send button. You will see an indication it is sending, then it will tell you the message was sucessfully sent.
__________________
Current: 2013 Monte Carlo Blue F10 M5 (ED on 9/1/12), 2014 Anvil Willys Wheeler Jeep Wrangler (weekend toy)
Previous: 2009 Carbon Black E60 M5, 2006 Silverstone II E60 M5, 2003 Sterling Grey E39 M5, 2000 Anthracite E39 540i6, 1998 Jeep Grand Cherokee 5.9 Limited, 1990 Eagle Talon TSi AWD, 1978 Mazda RX-7

Last edited by AGS; 01-10-2013 at 08:49 PM.
AGS is offline  
0
Reply With Quote
      01-10-2013, 07:06 PM   #18
cpdp
Private First Class
 
Drives: BMW
Join Date: Apr 2012
Location: Austria

Posts: 114
iTrader: (0)

what do you expect from the nav? it's just a 4000$ option
cpdp is offline  
0
Reply With Quote
      01-10-2013, 09:42 PM   #19
sfm5
New Member
 
Drives: F10 M5
Join Date: Dec 2009
Location: SF

Posts: 15
iTrader: (0)

Quote:
Originally Posted by AGS View Post
First google an address.
Left click on the pindrop, select more, then select send.
When the dialog box comes up select send to car.
Under the "Make" select BMW and enter the email address you have set up with BMW Assist.
Click the Send button. You will see an indication it is sending, then it will tell you the message was sucessfully sent.
When you do this, you're really only sending the address to the car. The car's NAV is still doing all the work. It's not following any Google directions. That would be quite the programming achievement if it worked that way.

Maybe your previous problems were caused by entering a vague address?
sfm5 is offline  
0
Reply With Quote
      01-10-2013, 10:20 PM   #20
mwlmd
Major
 
mwlmd's Avatar
 
Drives: F10 M5
Join Date: May 2009
Location: Portland, OR

Posts: 1,196
iTrader: (0)

Quote:
Originally Posted by sfm5
Quote:
Originally Posted by AGS View Post
First google an address.
Left click on the pindrop, select more, then select send.
When the dialog box comes up select send to car.
Under the "Make" select BMW and enter the email address you have set up with BMW Assist.
Click the Send button. You will see an indication it is sending, then it will tell you the message was sucessfully sent.
When you do this, you're really only sending the address to the car. The car's NAV is still doing all the work. It's not following any Google directions. That would be quite the programming achievement if it worked that way.

Maybe your previous problems were caused by entering a vague address?
I have been entering specific street addresses. Everything it asks for.
__________________
F10 M5
Alpine/Sakhir/Anthracite/DCT

HRE P101. Akrapovič evolution. H&R. Bell StiR+ Laser Interceptor quad. IND cosmetics. 3M CR50.
mwlmd is offline   United_States
0
Reply With Quote
      01-10-2013, 10:44 PM   #21
h4nh
Captain
 
h4nh's Avatar
 
Drives: 09 SC E90 M3 / 13 F10 M5
Join Date: Sep 2011
Location: Dallas, TX

Posts: 802
iTrader: (0)

Garage List
2013 M5  [0.00]
2009 E90 M3 (superc ...  [5.00]
I don't expect much from factory nav from any car. I haven't been in one that hasn't been frustrating. Garmin or iPhone is much easier.
__________________
h4nh is online now   United_States
0
Reply With Quote
      01-10-2013, 11:56 PM   #22
ImpetuousRacer
Private First Class
 
ImpetuousRacer's Avatar
 
Drives: 2013 BMW M5
Join Date: Oct 2012
Location: Scottsdale, AZ

Posts: 199
iTrader: (0)

Garage List
2013 BMW M5  [0.00]
Used it once, took me to the wrong place. I'm in AZ. I just use iPhone Nav... as sad as that sounds.
__________________
ImpetuousRacer is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:37 PM.




m5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST