M5POST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   M5POST - BMW M5 Forum > F10 M5 Forum > BMW M5 (F10) General Forum

Post Reply
 
Thread Tools Search this Thread
      04-14-2013, 06:55 PM   #1
py0413
Major
py0413's Avatar
Canada
19
Rep
1,178
Posts

 
Drives: 2012 M5
Join Date: Jul 2008
Location: BC

iTrader: (2)

Solid orange engine light came on

Good afternoon/evening folks,

I went for a 150km Sunday afternoon drive today. (Cruising speed, didn't push the car) On the way home, about 50km away, the orange engine light came on silently. I stopped at a gas station checking things up. Fuel door was tight and sealed. Checked with idrive and shows system all OK. The light remained on after restarting the car a couple of times. I read the owner's manual book and the only thing I could get was "emission Canadian mode", nothing else. Therefore, I proceed to call BMW assist and described to what happened. The rep said I could keep driving as long as it doesn't turn red and will visit a local BMW service center tomorrow for that error.

Is there a way to read out the error code like I could in the E9X? Makes me wonder what caused the light to come on, especially I didn't get any audio warning like I used to get in the other BMWs. 2 weeks ago when the car needed 1L of oil, I did get any audio warning along with a message showing on the display.

Any thoughts guys?
__________________
Must stop eating..............
Appreciate 0
      04-14-2013, 07:34 PM   #2
aculeg87
Captain
aculeg87's Avatar
United_States
15
Rep
879
Posts

 
Drives: M4 & 991S- GT3 being built
Join Date: Sep 2009
Location: NY

iTrader: (0)

Same thing happened to me today 30 seconds after starting the car. Fuel cap is tight too. Everything feels right. I'm annoyed because now I will probably have to waste time and go to the dealer. I should have never sold my scan tool.
Appreciate 0
      04-14-2013, 07:40 PM   #3
koxal
Her Zaman Her Yerde
koxal's Avatar
United_States
33
Rep
1,142
Posts

 
Drives: 2013 SG F10 M5
Join Date: Feb 2010
Location: North Jersey

iTrader: (7)

Garage List
2010 BMW M3  [0.00]
2013 BMW M5  [0.00]
so many problems with the f10 m5...

oil pump
fuel pump
brake squeaks
steering wheel vibration
drivetrain mulfaction
wind noise caused by mirrors
etc
etc etc...
__________________
Sold My Black Beast

Here is the new ride
Appreciate 0
      04-14-2013, 07:49 PM   #4
py0413
Major
py0413's Avatar
Canada
19
Rep
1,178
Posts

 
Drives: 2012 M5
Join Date: Jul 2008
Location: BC

iTrader: (2)

So an hour later now, I went to the garage and started up the car, the CEL is gone

if I am buying a scan tool/reader, which brand/model would you guys recommend?
__________________
Must stop eating..............
Appreciate 0
      04-14-2013, 07:49 PM   #5
aculeg87
Captain
aculeg87's Avatar
United_States
15
Rep
879
Posts

 
Drives: M4 & 991S- GT3 being built
Join Date: Sep 2009
Location: NY

iTrader: (0)

Quote:
Originally Posted by koxal View Post
so many problems with the f10 m5...

oil pump
fuel pump
brake squeaks
steering wheel vibration
drivetrain mulfaction
wind noise caused by mirrors
etc
etc etc...
Don't forget rear suspension clunk. (I haven't experienced it, I just am aware.)

I love this car, but yes I am disappointed in some ways.
Appreciate 0
      04-14-2013, 07:51 PM   #6
aculeg87
Captain
aculeg87's Avatar
United_States
15
Rep
879
Posts

 
Drives: M4 & 991S- GT3 being built
Join Date: Sep 2009
Location: NY

iTrader: (0)

Quote:
Originally Posted by py0413 View Post

if I am buying a scan tool/reader, which brand/model would you guys recommend?
I had a Peake research I was using on my E60. No complaints. I was just using it for a reset and scan for simple CEL.
Appreciate 0
      04-14-2013, 08:15 PM   #7
koxal
Her Zaman Her Yerde
koxal's Avatar
United_States
33
Rep
1,142
Posts

 
Drives: 2013 SG F10 M5
Join Date: Feb 2010
Location: North Jersey

iTrader: (7)

Garage List
2010 BMW M3  [0.00]
2013 BMW M5  [0.00]
Quote:
Originally Posted by aculeg87 View Post
Don't forget rear suspension clunk. (I haven't experienced it, I just am aware.)

I love this car, but yes I am disappointed in some ways.
yeap..! u r right.. i forgot to mention that with many others probably
__________________
Sold My Black Beast

Here is the new ride
Appreciate 0
      04-15-2013, 11:36 AM   #8
Sharpie12
Lieutenant
United_States
7
Rep
433
Posts

 
Drives: 2013 F10 M5 SG/SO
Join Date: Aug 2009
Location: Chicago

iTrader: (0)

happened to me a few weeks ago and my issue was that i was running too lean. Put in a fuel additive and filled up my gas, cleared the code and now im good.
__________________
2013 F10 M5 - SG/SO - Current
2010 E60 M5 - Retired
2010 X6 50i - Retired
2006 E60 M5 - Retired
2004 E60 530i - Retired
Appreciate 0
      04-15-2013, 12:17 PM   #9
krown
Private
krown's Avatar
1
Rep
74
Posts

 
Drives: 2012 F10 M5
Join Date: Jan 2013
Location: Vancouver

iTrader: (0)

Sorry to hear that. Let us know what the issue was when you find out!
Appreciate 0
      04-15-2013, 12:51 PM   #10
singularity
Driver
singularity's Avatar
35
Rep
640
Posts

 
Drives: M5 (F10)
Join Date: Dec 2011
Location: Slovakia

iTrader: (0)

That light isn't about an engine issue but about emission system malfunction. I've had it during cold starts, together with a drivetrain warning few months ago and it wouldn't go away until BMW service updated software and that fixed it.
Appreciate 0
      04-15-2013, 02:15 PM   #11
reychen123
Private
1
Rep
54
Posts

 
Drives: m5 f10
Join Date: Dec 2012
Location: arizona

iTrader: (0)

Had light on before, and it was something oxygen sensor not work. A problem I never heard of....
Appreciate 0
      04-15-2013, 04:49 PM   #12
aculeg87
Captain
aculeg87's Avatar
United_States
15
Rep
879
Posts

 
Drives: M4 & 991S- GT3 being built
Join Date: Sep 2009
Location: NY

iTrader: (0)

Mine just randomly went off. Hmmm?
Appreciate 0
      04-15-2013, 05:35 PM   #13
py0413
Major
py0413's Avatar
Canada
19
Rep
1,178
Posts

 
Drives: 2012 M5
Join Date: Jul 2008
Location: BC

iTrader: (2)

So to update this with everyone,

The light hasn't came back on after restarting the car yesterday afternoon. (Car was parked in the garage for roughly 1 hour after last seeing the light). Called dealer service department and they said they can't diagnose anything because the light is now off. Was told to go back to them if it ever happens again and of course, has to be within their regular business hour.

Another thing though, I have been driving on highway for quit a bit lately, cruising speed, 90-100km/h. I got some pretty impressive gas mileage. My last tank of gas went for a bit more than 650km and this refuel last night showed, I will get 775km/tank, probably won't happen but man this thing uses less gas than my 3.7L Acura TL.
__________________
Must stop eating..............
Appreciate 0
      04-15-2013, 10:04 PM   #14
avlnch
Lieutenant Colonel
24
Rep
1,574
Posts

 
Drives: 2013 Individual M5
Join Date: Jul 2007
Location: South FL

iTrader: (0)

Quote:
Originally Posted by py0413
Good afternoon/evening folks,

I went for a 150km Sunday afternoon drive today. (Cruising speed, didn't push the car) On the way home, about 50km away, the orange engine light came on silently. I stopped at a gas station checking things up. Fuel door was tight and sealed. Checked with idrive and shows system all OK. The light remained on after restarting the car a couple of times. I read the owner's manual book and the only thing I could get was "emission Canadian mode", nothing else. Therefore, I proceed to call BMW assist and described to what happened. The rep said I could keep driving as long as it doesn't turn red and will visit a local BMW service center tomorrow for that error.

Is there a way to read out the error code like I could in the E9X? Makes me wonder what caused the light to come on, especially I didn't get any audio warning like I used to get in the other BMWs. 2 weeks ago when the car needed 1L of oil, I did get any audio warning along with a message showing on the display.

Any thoughts guys?
How much gas was in your tank at the time you stopped at the gas station?

When you run the car low on gas, it's not very good for the fuel pump and components, and can yield a CEL (check engine light).

If you added fuel and the light went away after the car had time to reset, then you should be fine. This means it's not an O2 sensor or other emissions malfunction.. most likely it happened simply due to fueling up with an almost empty tank.
__________________
2013 BMW INDIVIDUAL ///M5 {Frozen Black/Amaro Brown/Amaro Brown Alcantara/White Contrast Stitching/Piano Black Trim}
Appreciate 0
      04-15-2013, 11:07 PM   #15
py0413
Major
py0413's Avatar
Canada
19
Rep
1,178
Posts

 
Drives: 2012 M5
Join Date: Jul 2008
Location: BC

iTrader: (2)

At the time when the light went on, I still had 1/2 tank of gas. I ran pretty low over the last 2 fill-ups. I wonder if that could be the cause. But definitely, when I had the CEL, the fuel tank had quite a bit of gas in it.
__________________
Must stop eating..............
Appreciate 0
      04-16-2013, 04:40 AM   #16
johntomferg
Lieutenant
United_States
8
Rep
581
Posts

 
Drives: 2013 BMW M5
Join Date: May 2012
Location: Columbia, TN

iTrader: (0)

Quote:
Originally Posted by py0413 View Post
So to update this with everyone,

The light hasn't came back on after restarting the car yesterday afternoon.

(...)

I got some pretty impressive gas mileage. My last tank of gas went for a bit more than 650km and this refuel last night showed, I will get 775km/tank, probably won't happen but man this thing uses less gas than my 3.7L Acura TL.


PY0413,

Glad your issue appears to have passed for the moment. Singularity is right that if you see it again, you should ask your dealer to check with BMW for a software update with an emissions issue that causes the CEL to intermittently come on.


Hey KOXAL,

Better add to your list:

Emissions CELs sometimes clear themselves without a trip to the dealer
Gas Mileage too good

Wouldn't want to miss those on your complaint/issues list for when you repeat the list in a new thread.
Appreciate 0
      04-16-2013, 07:46 AM   #17
DrewM5
Captain
6
Rep
636
Posts

 
Drives: SG E60 M5
Join Date: Sep 2012
Location: New York

iTrader: (0)

Quote:
Originally Posted by py0413 View Post
So to update this with everyone,

The light hasn't came back on after restarting the car yesterday afternoon. (Car was parked in the garage for roughly 1 hour after last seeing the light). Called dealer service department and they said they can't diagnose anything because the light is now off. Was told to go back to them if it ever happens again and of course, has to be within their regular business hour.

Another thing though, I have been driving on highway for quit a bit lately, cruising speed, 90-100km/h. I got some pretty impressive gas mileage. My last tank of gas went for a bit more than 650km and this refuel last night showed, I will get 775km/tank, probably won't happen but man this thing uses less gas than my 3.7L Acura TL.
Sounds like BS. They should be able to plug you in and get a history of all faults, errors, etc. I think they are just being lazy.
__________________
2014 M5 Competition|Space Grey|Black Merino Full Leather|Anthracite Trim|Executive package|LED Lighting Package|Drivers's Assit Package|B&O Sound System|Bel STiR Plus 9500ci|IND Side Markers and Side Vents|Exhaustmeister|HRE P101 Satin Charcoal/Michelin PSS (Summer)|601/Pirelli Sottozero Serie II (Winter)|Coded by V12
Appreciate 0
      04-16-2013, 06:30 PM   #18
py0413
Major
py0413's Avatar
Canada
19
Rep
1,178
Posts

 
Drives: 2012 M5
Join Date: Jul 2008
Location: BC

iTrader: (2)

I will be going to the dealer where my car was originally purchased, I will mention this CEL at check-in on Friday.
__________________
Must stop eating..............
Appreciate 0
      04-16-2013, 11:41 PM   #19
avlnch
Lieutenant Colonel
24
Rep
1,574
Posts

 
Drives: 2013 Individual M5
Join Date: Jul 2007
Location: South FL

iTrader: (0)

Quote:
Originally Posted by py0413
I will be going to the dealer where my car was originally purchased, I will mention this CEL at check-in on Friday.
Your name and the issue your having is pretty ironic. Gave me a quick laugh.

P0413 is an engine error code that throws a CEL light.

So you know, all the Dealer will do is plug your car up and check the faults log. It's possible that they won't find anything (sometimes these just don't register for some reason). However it only takes under 20 minutes to check things out, so doesn't hurt to ask them to plug it in and take a look.

Let us know how you make out..
__________________
2013 BMW INDIVIDUAL ///M5 {Frozen Black/Amaro Brown/Amaro Brown Alcantara/White Contrast Stitching/Piano Black Trim}
Appreciate 0
      04-17-2013, 01:55 PM   #20
py0413
Major
py0413's Avatar
Canada
19
Rep
1,178
Posts

 
Drives: 2012 M5
Join Date: Jul 2008
Location: BC

iTrader: (2)

Oh nooo! That really is ironic lol. No wonder my E90 m3 had CEL came up quite often. Nothing really was wrong but the sensors decided to go wild.

I will talk to the SA on Friday and see what they can do about it. As for now, the car runs great.
__________________
Must stop eating..............
Appreciate 0
      04-17-2013, 04:28 PM   #21
cmhsam
Major
24
Rep
1,276
Posts

 
Drives: 2013 F10 M5
Join Date: Mar 2012
Location: USA

iTrader: (0)

My car is getting new brakes and new driver side mirror. They also checked my fault code and said it has to do with the CAM SENSOR? They cant seem to resolve it so they needed to keep car for one more night. Hopefully will have an update tomorrow.
Appreciate 0
      04-17-2013, 04:48 PM   #22
skrambles297
Private First Class
1
Rep
105
Posts

 
Drives: M5 (Black Sapphire) F10
Join Date: Apr 2012
Location: London

iTrader: (0)

Quote:
Originally Posted by cmhsam View Post
My car is getting new brakes and new driver side mirror. They also checked my fault code and said it has to do with the CAM SENSOR? They cant seem to resolve it so they needed to keep car for one more night. Hopefully will have an update tomorrow.
Out of curiosity, what's the issue with the driver side mirror?
__________________
______________________
Current Cars: M5 (F10) / Porsche 911 Turbo (997) / X5 40d Msport
Previous Cars: M5 (E60) / M3 (E46) / TVR Cerbera
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:18 AM.




m5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST