M5POST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   M5POST - BMW M5 Forum > F10 M5 Forum > Engine, Exhaust, Drivetrain Modifications

Post Reply
 
Thread Tools Search this Thread
      03-09-2017, 09:30 AM   #1
hank1170
Registered
0
Rep
4
Posts

Drives: 2013 F10 M5
Join Date: Feb 2017
Location: Korea

iTrader: (0)

RPM fluctuations

I currently own a 2013 M5 with 38,000 kms. The check engine light came on and started stalling at red lights. I took it to BMW service numerous times and they said that the intake was contaminated with oil and thats why the check engine light kept coming on. No explaination of why it was stalling. I took it back a few times and they said that my the compression on one bank was lower than the other. They still couldnt figure it out. They ended up replacing the engine which I thought would definately solve the problem.

It has been 2,800kms since engine replacement. When I have the car in N and rev the engine up to 3,500-4,000 rpms, and let go of the gas pedal, the RPMs go down to 500rpms and then back to idle rpm of 700-800.

THis was happening with the old engine. I am afraid that the problem was not the engine itself. COuld it be one of the turbo is bad? My warranty has now expired, but would like this fixed. BMW service is telling me since there nothing is coming up on the computer so it's normal??? I have 2 friends with the same M5 and neither M5's do this. ANy help would be much appreciated.
Appreciate 0
      03-11-2017, 05:39 AM   #2
SapphireM5
Captain
SapphireM5's Avatar
492
Rep
873
Posts

Drives: 2013 M5 Sapphire Black
Join Date: Feb 2017
Location: New Jersey

iTrader: (3)

Try cleaning your maf sensors. They could have oil on them from previous oil contamination.
__________________
'13 Black Sapphire Metallic - BPM Stage 1 Tune - RPI Exhaust - KW HAS Kit - 12mm spacers all around- Carbon Fiber front lip - High Kick Trunk Spoiler - Rear Roof Spoiler - IND Kidney and Fender Grills - 20% Tint all around 50% Front Windshield - PPF
Appreciate 1
      03-11-2017, 08:48 AM   #3
13M5F10
Hide! My wife's coming!
13M5F10's Avatar
United_States
608
Rep
2,269
Posts

Drives: 2013 BMW M5 | MSR Stage 3
Join Date: Jun 2015
Location: Las Colinas, TX

iTrader: (5)

Definitely sounds like the MAF sensors are contaminated.

Pick up CRC Mass Air Flow Cleaner and follow the instructions. I would do it twice.

Hope that works.
__________________
*** SOLD *** 2013 BMW M5 | Space Grey | MSR Stage 3 Tune | Catless Downpipes | MSR Intake and Charge Pipes | MSR Exhaust (Prototype) | Vorsteiner Rear Diffuser | RW Carbon Front Lip | RW Carbon Trunk Spoiler| Vorsteiner VS-310 Forged Wheels | Escort 9500CI w/Laser Jammers
Appreciate 1
      03-12-2017, 04:55 AM   #4
hank1170
Registered
0
Rep
4
Posts

Drives: 2013 F10 M5
Join Date: Feb 2017
Location: Korea

iTrader: (0)

Have had BMW do that twice already and it was spotless.
Appreciate 0
      03-13-2017, 01:40 AM   #5
MpowerMike
Captain
MpowerMike's Avatar
132
Rep
955
Posts

Drives: 2012 IB BMW M5
Join Date: May 2014
Location: T.O. Canada

iTrader: (0)

Check your coils/plugs and o2 sensors.
Appreciate 1
      03-16-2017, 01:06 AM   #6
hank1170
Registered
0
Rep
4
Posts

Drives: 2013 F10 M5
Join Date: Feb 2017
Location: Korea

iTrader: (0)

Quote:
Originally Posted by MpowerMike View Post
Check your coils/plugs and o2 sensors.
Thank you for all the comments. will the computer not give a warning if any of these sensors are bad or not working properly? BMW Korea has been the least helpful since warranty has expired.
Appreciate 0
      07-24-2019, 10:35 AM   #7
tcrock08
New Member
tcrock08's Avatar
14
Rep
7
Posts

Drives: 2014 M5, 2010 335i Coupe
Join Date: Apr 2011
Location: Hong Kong

iTrader: (0)

hank1170 hi - just curious if problem surfaced again or if BMW Korea eventually figured it out?

My 2014 m5 has occasional engine stalls at start up / start stop and idling a little rough. No codes or check engine light. BMW HK tried replacing spark plugs and MAF sensors to no effect. So curious if you have an update on your car...
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:08 AM.




m5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST