M5POST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   M5POST - BMW M5 Forum > F10 M5 Forum > BMW M5 (F10) General Forum

Post Reply
 
Thread Tools Search this Thread
      01-04-2019, 02:39 PM   #23
Manny G
The Illustrious
United_States
15
Rep
102
Posts

Drives: 2003 540i/6 M-Sport, 2013 M5
Join Date: Apr 2013
Location: Coral Springs, FL

iTrader: (1)

I got curious about my fuel filter, and realized that when looking at realoem with my VIN, i dont see one?
Attached Images
 
__________________
'13 F10 M5
'03 E39 540i/6 M-sport
'81 E21 320i 'S'
'98 E36 M3/4 (sold)
Appreciate 0
      01-04-2019, 04:12 PM   #24
M5theonlyone
Captain
United Kingdom
220
Rep
847
Posts

Drives: BMW M5
Join Date: Aug 2018
Location: Southern England

iTrader: (0)

Garage List
2013 BMW M5  [5.00]
Quote:
Originally Posted by Manny G View Post
I got curious about my fuel filter, and realized that when looking at realoem with my VIN, i dont see one?
All UK and European M5 F10's have one, the one on mine was changed at 17000mi on service schedule.I suggested to someone else on their US M5 to loosen the under floor aero and take a look there around the middle of the floor pan if there is something there which has a metal shield covering it.There must be something or what would stop microscopic debris making their way to the...injectors.
Appreciate 0
      01-07-2019, 05:17 PM   #25
TLK
Second Lieutenant
TLK's Avatar
66
Rep
260
Posts

Drives: '14 M5 CP, '12 550i, '04 545i
Join Date: Sep 2016
Location: SF Bay, CA

iTrader: (0)

Yeah well I already broke down the lift and put it away and I don't want to get it out again just to go look for the fuel filter

Maybe lack of a filter is why I got a letter from BMW NA saying something about the warranty for injector problems has been extended...
Appreciate 0
      01-08-2019, 01:34 AM   #26
Craze
First Lieutenant
57
Rep
327
Posts

Drives: M5 E60, M5 F10, X5 50i
Join Date: Oct 2017
Location: Australia

iTrader: (0)

Its built into pump i think
Appreciate 0
      01-08-2019, 08:24 AM   #27
M5theonlyone
Captain
United Kingdom
220
Rep
847
Posts

Drives: BMW M5
Join Date: Aug 2018
Location: Southern England

iTrader: (0)

Garage List
2013 BMW M5  [5.00]
If not there under the floor (it was only a suggestion from me) then it may be on top of the fuel tank on the left (on US drivers side) opposite side to the fuel pump after taking back seat off.Again,it's after what I saw and read so don't take it as gospel from me.
Appreciate 0
      01-09-2019, 03:28 PM   #28
TLK
Second Lieutenant
TLK's Avatar
66
Rep
260
Posts

Drives: '14 M5 CP, '12 550i, '04 545i
Join Date: Sep 2016
Location: SF Bay, CA

iTrader: (0)

Quote:
Originally Posted by Craze View Post
Its built into pump i think
That's what I think too. On e39 or e60 it was on the pump and no separate filter. "Lifetime " filter, i.e. the life of the pump and filter, not your car.

On much older BMWs with a inline filter, you had to replace it after X years because it just swells up over time and isn't necessarily clogged with dirt. On those cars there was something like a mesh bag over the pump inlet in the tank as a first stage filter. I sure hope there is something better than that on the US F10.
Appreciate 0
      02-07-2019, 11:09 AM   #29
Manny G
The Illustrious
United_States
15
Rep
102
Posts

Drives: 2003 540i/6 M-Sport, 2013 M5
Join Date: Apr 2013
Location: Coral Springs, FL

iTrader: (1)

Had the car smoke tested, no leaks found. Reset the adaptations with Autologic diag computer, drove the car, no CEL turned back on.

Turns out that after replacing the MAFs with new ones, I needed to have the adaptations manually reset. Hind sight, the original issue the car had which lead to being taken to the dealer the first time was more than likely linked to dirty MAFs. The dealership changed a whole lot of stuff to my benefit when they would have been fine just cleaning the MAFs and clearing adaptations.
__________________
'13 F10 M5
'03 E39 540i/6 M-sport
'81 E21 320i 'S'
'98 E36 M3/4 (sold)
Appreciate 0
      03-13-2019, 02:29 PM   #30
Manny G
The Illustrious
United_States
15
Rep
102
Posts

Drives: 2003 540i/6 M-Sport, 2013 M5
Join Date: Apr 2013
Location: Coral Springs, FL

iTrader: (1)

This got more complicated.

Turns out that there was a leak found when smoke testing from the exhaust side. After that was fixed, fuel flow was incorrect. Sent the car back to a different dealer, they found out that the last dealer installed the wrong injectors. The ECU was looking for EU5 injectors, I had EU6 injectors incorrectly installed by the dealership when they were shotgunning the repairs.

All good now.
__________________
'13 F10 M5
'03 E39 540i/6 M-sport
'81 E21 320i 'S'
'98 E36 M3/4 (sold)
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:24 AM.




m5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST